Weird Rails Gem

After updating rails I got an error ala `require_frameworks’:RuntimeError: RubyGem version error: rack(1.0.0 not ~> 1.0.1)

The solution is simple:

$ sudo gem install rack –version 1.0.1

2. problem: libxml2 is missing.  try ‘port install libxml2’ or ‘yum install libxml2-devel’


$ sudo apt-get install libxml2-dev

I also needed libxslt-dev to install the ruhl gem after that nokogiri-1.4.1 and ruhl-1.3.4 were successfully installed.

The only problem is now that ruhl woudn’t work with jruby 😦 …